Rear star won’t go flush

A place to talk.
Post Reply
Vulgarian
New User
New User
Posts: 53
Joined: Thu Apr 20, 2017 8:20 pm
x 2

Rear star won’t go flush

Post by Vulgarian » Tue Feb 05, 2019 11:48 am

Hi guys,

Anyone any ideas how to get these clips in?
Bought a new gloss black badge and one of the clips won’t go flush, see picture -
Image
0 x

rjc_147
A45 Newbie
A45 Newbie
Posts: 157
Joined: Sun Feb 26, 2017 11:38 am
x 12

Re: Rear star won’t go flush

Post by rjc_147 » Tue Feb 05, 2019 12:27 pm

Looks like you may need to trim some plastic off the diameter of the tab.
Make sure all the tabs look the same in diameter and length

Does it come with adhesive tape on the back?
0 x
FL A45 Mountain Grey | Premium pack | AMG Exclusive pack

User avatar
MAFFA
Moderator
Moderator
Posts: 4415
Joined: Wed Dec 21, 2016 10:03 pm
Location: Bognor Regis
x 485
Contact:

Re: Rear star won’t go flush

Post by MAFFA » Tue Feb 05, 2019 10:02 pm

Yeah as mentioned it looks like one needs a trim. Even if it’s over trimmed the other 2 should hold it flush anyway
0 x
2014 A45 AMG ¦ Jupiter Red ¦ AMG Aero Pack ¦ AMG De-Resonated Sports Exhaust ¦ 19" AMG Alloys ¦ AMG Exclusive Pack ¦ Full Leather incl. Heated Seats & Leather Dashboard ¦ Panoramic Sunroof ¦ AMG Night Pack ¦ Privacy Glass

Vulgarian
New User
New User
Posts: 53
Joined: Thu Apr 20, 2017 8:20 pm
x 2

Re: Rear star won’t go flush

Post by Vulgarian » Thu Feb 07, 2019 8:18 am

Ended up taking it to someone that knows what they’re doing haha! Didn’t need trimming in the end but we took the plastic plugs out and pushed them onto the badge and then put it on the car
1 x

Post Reply